Silva Issue Tracker Archive: Issue1653

 This tracker has been migrated to Launchpad. Please post new messages at: https://bugs.launchpad.net/silva.
Title table widths problems with firefox-2.0.0.1
Priority bug Status resolved
Superseder Kupu Error when changing Number of Table-Columns (list)
View: 1577
Nosy List jasper, kitblake, mpetit, thisfred (list)
Assigned To jasper Topics Silva-1.5 (list)

Created on 2007-01-18.22:35:51 by mpetit, last changed 2007-02-19.17:55:19 by kitblake.

Messages
msg9201 (view) Author: kitblake Date: 2007-02-19.17:55:11
Resolving, superceding with issue 1577 for workaround.
msg9089 (view) Author: jasper Date: 2007-02-06.17:18:44
Fixed this bug in silva (1.6) trunk.
Unfortunately we can't really change things in kupu for silva1.5

There's a workaround for 1.5 users, just click on the table, and the "column
width" field will be updated.

NOTE: this is the same as issue 1577
msg9017 (view) Author: mpetit Date: 2007-01-19.12:14:14
> Do you use the controls for adding columns too? If it worked it's an
> unknown feature of Kupu :-)

oh, yes. it works like a charm. i use this tool all the time because it is so
much more convenient than using the table toolbox. i use the toolbox only for
setting the style and adjusting the widths.
msg9016 (view) Author: kitblake Date: 2007-01-19.10:52:51
2007/1/19, Petitmermet Marc <issue-silva@infrae.com>:
> i'm surprised by your comment. i use those handles all the time with silva-1.1.5
> and don't have these width problems. so something broke...

Do you use the controls for adding columns too? If it worked it's an
unknown feature of Kupu :-)
msg9015 (view) Author: mpetit Date: 2007-01-19.09:24:41
> Those 'handles' or controls in the tables never worked. AFAIK, anyway.
> Did you use them in earlier Silva versions?

i'm surprised by your comment. i use those handles all the time with silva-1.1.5
and don't have these width problems. so something broke...
msg9003 (view) Author: kitblake Date: 2007-01-19.06:49:19
Those 'handles' or controls in the tables never worked. AFAIK, anyway.
Did you use them in earlier Silva versions?

They're unique to Mozilla/Firefox, and since they're browser specific,
Kupu doesn't have code that hooks into them. The only way to adjust
tables is in the table toolbox. Changing, say the width or height of
the table by dragging doesn't work either.

It's really unfortunate that attempting to use the add controls messes
up the document, although I'm having trouble reproducing the error
(but I'm not doubting that it occurred :-))
msg9002 (view) Author: mpetit Date: 2007-01-18.22:35:49
it seems that in silva-1.5.9 working with this crossed circle and two triangle
thingies in tables (what's the proper name for this?) does not work properly.
when working with this tool the column widths field does not get updated
correctly. and when trying to manually correct it i get the error message
"number of widths doesn't match number of columns!". cleanup, update table,
saving, closing and reopening the document does not help. the newly created
column is also extremely small. it seems to split with widths 100:1; i have seen
this "100" several times. the color of the update table button suggests that it
is always pressed even when released.
History
Date User Action Args
2007-02-19 17:55:19kitblakesetstatus: testing -> resolved
2007-02-19 17:55:11kitblakesetsuperseder: + Kupu Error when changing Number of Table-Columns
messages: + msg9201
2007-02-06 17:18:44jaspersetstatus: chatting -> testing
messages: + msg9089
2007-02-06 14:04:01thisfredsetnosy: + jasper
assignedto: jasper
2007-01-19 12:14:14mpetitsetmessages: + msg9017
2007-01-19 10:52:51kitblakesetmessages: + msg9016
2007-01-19 09:24:42mpetitsetmessages: + msg9015
2007-01-19 06:49:23kitblakesetstatus: unread -> chatting
messages: + msg9003
2007-01-18 22:35:51mpetitcreate