Silva Issue Tracker Archive: Issue913

 This tracker has been migrated to Launchpad. Please post new messages at: https://bugs.launchpad.net/silva.
Title Approving with explicit time set results in error
Priority bug Status done-cbb
Superseder (list) Nosy List faassen, flynt, johnny, jw, kitblake (list)
Assigned To jw Topics Silva-0.9.3, Silva-1.0, ui (list)

Created on 2004-04-13.14:34:51 by faassen, last changed 2004-05-18.16:48:01 by jw.

Messages
msg5828 (view) Author: jw Date: 2004-05-18.16:48:01
This issue cannot be reproduced in a regular fashion...

Somehow, sometimes, get_member (on the member service) return None instead of a
NoneMember (for unkown userids). I just catch this case now and continue the loop.

I set this issue to done could be better.
Please test (e.g. by watching the event log file messages that indicate the
get_member() indeed returned None...)
msg5758 (view) Author: faassen Date: 2004-05-09.21:29:43
Moving this from need-eg back to in-progress.
msg5688 (view) Author: jw Date: 2004-04-29.19:00:46
aha, ok, they are now.. dunno what happens here, but I'll investigate.
msg5684 (view) Author: jw Date: 2004-04-29.18:08:16
so far, none of the reported issue are reproducible by me... sorry..
msg5675 (view) Author: kitblake Date: 2004-04-29.17:14:03
After cvs upping, I can't publish anything.
msg5674 (view) Author: kitblake Date: 2004-04-29.16:57:10
Hmmm, I get the same error when I, as Author, *do* have an email address set. 

Also, there *is* a ChiefEditor who *does* have an email address.
msg5672 (view) Author: kitblake Date: 2004-04-29.16:51:38
I get the same error when logged in as Author and requesting approval for
content - in this case a Link - in the Content Publish Screen. A datetime is
automatically filled in in this screen, unlike the Publish screen above.

The error "'None' object has no attribute 'email'" is caused when the Email
Messaging Service is turned on, but the user has no email address in the system.
msg5538 (view) Author: faassen Date: 2004-04-13.14:34:51
When I try to approve but instead of 'publish now' I set a specific publication
date, I get this traceback:

Traceback (innermost last):
  Module ZPublisher.Publish, line 98, in publish
  Module ZPublisher.mapply, line 88, in mapply
  Module ZPublisher.Publish, line 39, in call_object
  Module Products.FileSystemSite.FSPythonScript, line 104, in __call__
  Module Shared.DC.Scripts.Bindings, line 306, in __call__
  Module Shared.DC.Scripts.Bindings, line 343, in _bindAndExec
  Module Products.FileSystemSite.FSPythonScript, line 160, in _exec
  Module None, line 91, in tab_status_approve
   - <FSPythonScript at
/silva/service_views/Silva/edit/Container/tab_status_approve used for
/silva/service_views/Silva/edit/Container/Folder>
   - Line 91
  Module Products.Silva.EmailMessageService, line 128, in send_pending_messages
AttributeError: 'None' object has no attribute 'email'
History
Date User Action Args
2004-05-18 16:48:02jwsetstatus: in-progress -> done-cbb
messages: + msg5828
2004-05-09 21:29:43faassensetstatus: need-eg -> in-progress
messages: + msg5758
2004-04-29 19:00:46jwsetmessages: + msg5688
2004-04-29 18:08:16jwsetstatus: chatting -> need-eg
messages: + msg5684
2004-04-29 17:14:04kitblakesetmessages: + msg5675
2004-04-29 16:57:10kitblakesetmessages: + msg5674
2004-04-29 16:51:38kitblakesetstatus: unread -> chatting
nosy: + johnny
messages: + msg5672
2004-04-26 22:36:45flyntsetnosy: + flynt
2004-04-16 15:21:15faassensetassignedto: jw
2004-04-13 14:34:51faassencreate